using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""totalCash\"":\""(?<totalCash>\d+)\"",\""passenger\"":\""(?<passenger>[^\""]+)";
string input = @"2022-07-15 14:30:43 , Oracle WebLogic Server is fully supported on Kubernetes , xsjhjediodjde,""approvalCode"":""YES"",""totalCash"":""85000"",""passenger"":""A"",dgegrgrg4t3g4t3g4t3g4t,rgrfwefiuascjcusc,
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}