$re = '~\b[-+×÷*/]~m';
$str = '-7.89-2.45";
7.89-2.45
-7.89--2.45';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);