package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\/gamma\/|\b(truck|\?|face)\b`)
var str = `/gamma/ truck?timer!doctor\\face`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}