re = /^(?!.*?(?<=^|\;)[a-zA-Z]+( [a-zA-Z]+)*(\=[^\;]+?\=[^\;]*)?(\;|$))+([a-zA-Z]+( [a-zA-Z]+)*\=[^\;]+\;?)+$/
str = 'option=value;missingvalue;multiple assignment=123=456'
# Print the match result
str.match(re) do |match|
puts match.to_s
end