package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[^\x{100}-\x{ffff}]*[\x80-\xff]`)
var str = `a é`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}