package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\/(.+?)\.\w+\/`)
var str = `https://regex101.com
https://regex_101.com
https://regex-101.com
https://regex.101.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}