$re = '/(?i)^[^@]*@(?!.*abc).*/m';
$str = 'abc@gmail.com
james@abc.com
james@something-and-abc.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);