re = /(?i)^[^@]*@(?!abc).*/m
str = 'abc@gmail.com
james@abc.com
james@something-and-abc.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end