$re = '/^\s*(\d+)\b(?!\.)/m';
$str = '5000 #this is 5 seconds
5000 # this is 5 seconds
5000.00 #this is 5 seconds
s5000 # this is 5 seconds';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);