$re = '/\b(?:(?:h(?:im|er))|(?:s?he)|(?:the[m y]))\b/m';
$str = 'he him
she her
they them';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);