$re = '/(?<=<span id=subheader>)(.*)(?=<\Sspan)/m';
$str = '<span id=subheader>Unknown Events</span>
<span id=subheader>Mission here</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);