re = /^(?!\d)[\w_.-]+@[\w_.-]+\.[a-zA-Z]+$/m
str = '4test@example.com
t@example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end