const regex = /^[ \-0-9a-zA-ZäöüÄÖÜß.]+?\s+(\d+(\s?[a-zA-Z])?)\s*(?:$|\(|[A-Z]{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[ \\-0-9a-zA-ZäöüÄÖÜß.]+?\\s+(\\d+(\\s?[a-zA-Z])?)\\s*(?:$|\\(|[A-Z]{2})', 'gm')
const str = `Lilienstr. 12a
Hagentorwall 3
Seilerstr. 14 (Eingang Birkenstr.)
Guentherstr. 43 B
Straße des 17. Juni 1
Eberhard-Leibnitz Str. 1 WH 5B 241
1019-1781 Borderlinx C/O SEKO Logistics
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}