package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m),\s*([^,\n]*)$`)
var str = `country
China Anhui Univ Chinese Med, Affiliated Hosp 1, Expt Ctr Clin Res, Sci Res Dept, 117 Meishan Rd, Hefei 230031, Anhui, 12, Peoples R China
Meluna Res, Geldermalsen, Netherlands; [Wiegant, Frederik Anton Clemens] Univ Utrecht, Utrecht, Netherlands`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}