use strict;
my $str = 'https://www.a;ldkfa.com
https://www.reddit.com/r/regex/comments/pejecb/match_url_without_https_part/
https://www.google.com/search?q=i+was+feeling+kinda+sea+sick&oq=i+was+feeling+kinda+sea+sick&aqs=chrome..69i57j69i64l3.6740j0j7&sourceid=chrome&ie=UTF-8
https://abc.com.
http://192.168.1.255/
';
my $regex = qr/^(?:htt(?:ps|p):\/\/www\.)(?=(.+\..{3,}))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}