package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^|[^\\])(?:\\{2})*("[^"\\]*(?:\\[\s\S][^"\\]*)*")`)
var str = ` ... \"foo "bar" ... goo"o"ooogle "t\"e\"st"[]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}