import re
regex = re.compile(r"Word1[\s:]*((?:.+\n)*)Word2", flags=re.MULTILINE)
test_str = ("Word1 content1 content1 content1\n"
" content2 content2 content2\n"
" \n"
" content3 content3 content3\n"
"Word2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")