$re = '@images/stimuli/\K\d+(?=\.png)@m';
$str = '<img src=\'images/stimuli/32.png\' style=\'width:341.38790035587186px;height: 265px;\'><img src=\'images/stimuli/36.png\' style=\'width:341.38790035587186px;height: 265px;\'>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);