$re = '/^([^:,]*):([^:,]*)/m';
$str = 'a:b,c:d
:v
w:,x:y
f:g,h:i,j:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);