re = /\A[a-z][a-z0-9.+-]*:\/\/(\w+:{0,1}\w*@)?(\S+)(:[0-9]+)?(\/|\/([\w#!:.?+=&%@!\-\/]))?\z/m
str = 'https://www.openstreetmap.org/diary'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end