const regex = /(?:testInputs|testVars)\.(?:[\w.](?!ISEMPTY|CONTAINS|OR|IN|[^\w.]))*\w/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:testInputs|testVars)\\.(?:[\\w.](?!ISEMPTY|CONTAINS|OR|IN|[^\\w.]))*\\w', 'gm')
const str = `testInputs.abc_def.alpha=abc^ORtestVars.var23.nameISEMPTY^testInputs.alpha_bravo.more.otheroneCONTAINSsomething^testVars.anotherone!=abc^testVars.mYVar!=abc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}