using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)'";
string input = @"Let\'s agree the single quotes in this sentence are already escaped, aren\'t they?
But let's also agree the ones in this sentence aren't.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}