package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\"cricket score : (?<cricket_score>[^\"]+)\",\"time\":\"(?<time>[^\"]+)`)
var str = `"host":"111.123.23.34","level":1,"msg":"cricket score : 10","time":"2023-07-11T17:28:33.265Z"
Event 2 : 7/11/23 6:28:33.265 PM
"host":"111.123.23.34","level":2,"msg":"cricket score : 20","time":"2023-07-11T18:28:33.265Z"
Event 3 : 7/12/23 5:28:33.265 PM
"host":"111.123.23.34","level":3,"msg":"cricket score : 30","time":"2023-07-12T17:28:33.265Z"
Event 4 : 7/12/23 6:28:33.265 PM
"host":"111.123.23.34","level":4,"msg":"cricket score : 40","time":"2023-07-12T18:28:33.265Z"
Event 5 : 7/13/23 5:28:33.265 PM
"host":"111.123.23.34","level"5,"msg":"cricket score : 50","time":"2023-07-13T17:28:33.265Z"
Event 6 : 7/13/23 6:28:33.265 PM
"host":"111.123.23.34","level":1,"msg":"cricket score : 10","time":"2023-07-13T18:28:33.265Z"
Event 7 : 7/14/23 5:28:33.265 PM
"host":"111.123.23.34","level":2,"msg":"cricket score : 20","time":"2023-07-14T17:28:33.265Z"
Event 8 : 7/14/23 6:28:33.265 PM
"host":"111.123.23.34","level":3,"msg":"cricket score : 30","time":"2023-07-14T18:28:33.265Z"
Event 9 : 7/15/23 5:28:33.265 PM
"host":"111.123.23.34","level":4,"msg":"cricket score : 40","time":"2023-07-15T17:28:33.265Z"
Event 10 : 7/15/23 6:28:33.265 PM
"host":"111.123.23.34","level"5,"msg":"cricket score : 50","time":"2023-07-15T16:28:33.265Z"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}