import re
regex = re.compile(r"^\+20(10|11|12|15)[0-9]{8}$", flags=re.MULTILINE)
test_str = ("+201001234567\n"
"+201101234567\n"
"+201201234567\n"
"+201501234567")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")