re = /^(?!.*?(?i)that).*$/m
str = 'I like this sentence.
I like that sentence.
I link THAT sentence.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end