re = /([^\[]*)\[(.*?)\]([^\[]*)/m
str = 'before brackets [inside brackets] after brackets'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end