package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\/([0-9]+)?|([a-z]+)?\.jpg|jpeg|png|gif)`)
var str = `http://site234.com/folder/ar.txt
http://jtem.com/folder/s.zip
http://site.com/folder/ddr
http://sit23e1.ru/folder/eff.jpg
http://spbrecommender.com/folder/karo.gif
http://site.eu/folder/spb.pdf
http://site.com/folder/lego.jpeg
http://sir.fr/folder/some.jpg
http://site.com/folder/erro.exe
http://personel.com/folder/1.png`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}