import re
regex = re.compile(r"^((([A-Z]{3})\-([0-9]{4})|([A-Z]{2}) ([A-Z]{2})\-([0-9]{3})|([A-Z]{4})\-([0-9]{3})|([A-Z]{5})\-([0-9]{2})|([A-Z]{6})\-([0-9]{1})|([A-Z]{3})\-([0-9]{3})|([A-Z]{4})\-([0-9]{2})|([A-Z]{5})\-([0-9]{1})))$", flags=re.MULTILINE)
test_str = ("ANH-1234\n"
"BRNO-123\n"
"HAROM-33\n"
"SZUPER-1\n"
"AA BE-123\n"
"HTC-123\n"
"FUGE-01\n"
"NEKEM-8")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")