package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)file_\d+_\S*_s\.txt`)
var str = `xxxxxxx File_6547845_Whateverishere_S_Md.Txt yyyyyyyyyyyyy File_14787547_Whateverishere_S.Txt zzzzzzzzzzzzz
File_6547845_Whateverishere_S_Md.Txt yyyyyyyyyyyyy File_14787547_Whateverishere_S.Txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}