using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"file_id\s*`([^`]*)`";
string input = @"Error: Unable to version with file_id `a123-4567-89001` on server `serverA`";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}