package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^upgrade(\d+)Step(\d+)$`)
var str = `upgrade1000170Step`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}