$re = '/(?<=^|b)[0-9]/m';
$str = '1 blabla 3 t 4. now mixed2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);