re = /^(([5,6,7,8,9]{1})([0-9]{1})([0,1,2,3,5,6,7,8]{1})([0-9]{6})([v|V|x|X]))|(([1,2]{1})([0,9]{1})([0-9]{2})([0,1,2,3,5,6,7,8]{1})([0-9]{7}))/m
str = '880053611V
198800503611
978561353V
199785601355
920600073V
199206000073'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end