$re = '/[-+]?[0-9]+\.[0-9]+(?:[eE][-+]?[0-9]+)?/';
$str = '-1.34e+32 +1.34e-32 .34e+32 .34 .3 34 .3e 123.456.789 Seq1..2.3.4.5 -.56 +.78
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);