$re = '/(?:where)?.*[.| ](?<phrase>(?<col>[a-z_]+).*?(?<opp>=|in)[\s(]*?["\'\s.{]+)(?<var>\$(?:[^"\s;}]+|"[^"\s;]+")*)(?<end>.*)/m';
$str = '$sql = "SELECT name FROM user WHERE id = $uuid";
--
$sql = "SELECT name FROM user WHERE id =" . $_REQUEST["user-id"];';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);