package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Python$`)
var str = `Python language
python algorithm
code Python
Python script`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}