use strict;
my $str = 'Test cases where it should match.
- [x] Example task. | Task ends. [x] Another task.
- [x] ! Example task. | This ends. [x] ! Another task.
This is a sentence. [x] Task is here.
Other text. Another [x] ! Task is here.
Must not match in the table.
| | Task name | Plan | Actual | File |
| :---- | :-------------| :---------: | :---------: | :------------: |
| [x] | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |
| [x] ! | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |
Groups expected:
$1: all text after [x]
$2: all text after [x] !
Regex for each group:
$1: [^|\\s]\\s*\\[x\\](?!\\s*!)\\s*\\K[^!|\\n]*
$2: [^|\\s]\\s*\\[x\\]\\s*!\\s*\\K[^|\\n]*
With the not-capturing group applied:
$1: (?:[^|\\s]\\s*\\[x\\](?!\\s*!)\\s*\\K([^!|\\n]*))
$2: (?:[^|\\s]\\s*\\[x\\]\\s*!\\s*\\K([^|\\n]*))
The combined expression:
(?:[^|\\s]\\s*\\[x\\](?!\\s*!)\\s*\\K([^!|\\n]*))|(?:[^|\\s]\\s*\\[x\\]\\s*!\\s*\\K([^|\\n]*))';
my $regex = qr/(?:[^|\s]\s*\[x\](?!\s*!)\s*\K([^!|\n]*))|(?:[^|\s]\s*\[x\]\s*!\s*\K([^|\n]*))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}