use strict;
my $str = 'abc@some-site.com
111@abcdefghijk.com1111
abc@abcdefghijk.com
';
my $regex = qr`^(.*([^\n@].{15}|.[^\na].{14}|.{2}[^\nb].{13}|.{3}[^\nc].{12}|.{4}[^\nd].{11}|.{5}[^\ne].{10}|.{6}[^\nf]).{9}|.{7}[^\ng].{8}|.{8}[^\nh].{7}|.{9}[^\ni].{6}|.{10}[^\nj].{5}|.{11}[^\nk].{4}|.{12}[^\n.].{3}|.{13}[^\nc].{2}|.{14}[^\no].|.{15}[^\nm]|.{0,15})$`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}