$re = '/(?x)
\( (?: \'(?>[^\']+|\'\')*\' | "(?>[^"]+|"")*" | [^\(\)]*? | (?R) )* \)/m';
$str = 'Func bla((2-5) + 8, "Ein( String ))", (7-8)+(5-(9-8))) ) ))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);