import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=timestamp:\\h)\\d+(?=\\h-)";
final String string = "### Size: 280\n"
+ "### file data: \n"
+ "### Scenario: - timestamp: 1620832134319 - Wed May 12 17:08:54 CEST 2021\n"
+ "### It needed to compare later timestamp: 1620832134319 - Wed May 12 17:08:54 CEST 2021";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}