re = /(AGGAGG)([ACGT]{4,12})(ATG)([ACTG]{3})*?(TAA|TAG|TGA)/m
str = 'AGGAGGTATGATGCGTACGGGCTAGTAGAGGAGGTATGATGTAGTAGCATGCT'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end