#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=\s*SELECT\s+([\s\S]*?)(?=\s+(?:INTO|FROM|WHERE|GROUP\s+BY|HAVING|ORDER\s+BY)\s))(?=(?:[\s\S]*?\s+INTO\s+([\S]+)\s*)?)(?=(?:[\s\S]*?\s+FROM\s+([\s\S]*?)(?=\s+(?:WHERE|GROUP\s+BY|HAVING|ORDER\s+BY)\s)))(?=(?:[\s\S]*?\s+WHERE\s+([\s\S]*?)(?=\s+(?:GROUP\s+BY|HAVING|ORDER\s+BY)\s)))(?=(?:[\s\S]*?\s+GROUP\s+BY\s+([\s\S]*?)(?=\s+(?:HAVING|ORDER\s+BY)\s))?)(?=(?:[\s\S]*?\s+HAVING\s+([\s\S]*?)(?=\s+ORDER\s+BY\s))?)(?=(?:[\s\S]*?\s+ORDER\s+BY\s+([\s\S]*?)(?=\s*$))).*$"
Local $sString = "SELECT" & @CRLF & _
" t1.dummy1," & @CRLF & _
" t1.dummy2, " & @CRLF & _
" t1.dummy3" & @CRLF & _
"INTO" & @CRLF & _
" testResult" & @CRLF & _
"FROM" & @CRLF & _
" (test1 t1" & @CRLF & _
" INNER JOIN test2 t2 ON t1.dummy4 = t2.dummy4)" & @CRLF & _
" INNER JOIN test3 t3 ON t2.dummy9 = t3.dummy9" & @CRLF & _
"WHERE" & @CRLF & _
" t2.dummy6 = 'abc'" & @CRLF & _
" AND t3.dummy10 <> 'def'" & @CRLF & _
" AND t1.dummy11 = 'ghi'" & @CRLF & _
" AND t2.dummy12 IS NULL" & @CRLF & _
"HAVING 1=1" & @CRLF & _
"ORDER BY 1;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")