$re = '/⏰\s?([0-9]{1,3})?(.*)/m';
$str = '⏰ 20 asdf 123 -\\*/=';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);