package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`AB|A|B`)
var str = `"A","B","AB" and which does not match "","AA","BB","BA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}