const regex = /(?s).*speed=\s*\K([^\v]*)(?=x.*$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s).*speed=\\s*\\K([^\\v]*)(?=x.*$)', 'g')
const str = `frame=13920 fps= 86 q=-1.0 size= 96512kB time=00:07:44.47 bitrate=1702.2kbits/s speed=2.88x
frame=14068 fps= 87 q=-1.0 size= 98048kB time=00:07:49.41 bitrate=1711.1kbits/s speed= 2.9x
frame=14116 fps= 87 q=-1.0 Lsize= 98954kB time=00:07:51.06 bitrate=1720.9kbits/s speed=2.91x
video:86252kB audio:3826kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 9.852874%`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}