package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\s"]+|"([^"]*)"`)
var str = `the cat in the hat "cat eats hat" "cat"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}