$re = '/"modelstub": \d+$/m';
$str = '"modelstub": "some-123908"
"modelstub": "00432"
"modelstub": "1607"
"modelstub": 16-02
"modelstub": 1605
"modelstub": 1604
"modelstub": 1603
"modelstub": "1-602"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);