re = /(?:,)([0-9]{7}[0-9A-F]{8})/
str = 'C7,22801422CFE0F63,2280141C5EF0F63,22801402EFD0F63,2280138C5ED0F63,228024329897530,228023829877530'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end