import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-z]+)(?:([A-Z]{1})([a-z]+))+$";
final String string = "myjfgfgffhVarBaThisVinoth\n"
+ "myVar\n"
+ "MYVAR\n"
+ "my-var\n"
+ "my.var\n"
+ "Myvar\n"
+ "My var\n"
+ "my var\n"
+ "Myvar\n"
+ "myvar\n"
+ "my Var\n"
+ "myVar \n"
+ "myVAR\n"
+ "myVARandV\n"
+ "my_var\n"
+ "myVarAndV\n"
+ "myAndVar\n"
+ "myV_ar\n"
+ "my_Var\n"
+ "my*Var\n"
+ "myV*ar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}