$re = '/_.([A-Z]+)/';
$str = '_AAAA_BBB_CC';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);